Hey everybody, I'm new here and totally new to Studio Artist, as well. So far I'm loving the program--everything I create in the program looks amazing! But I'm having trouble exporting finished videos OUT of the program that actually play. I did receive a nice email from Peter here when I emailed Support but he also asked that I post my questions here on the forum so others can see and chime in.

Basically, what I'm trying to do is use a pre-exiting mp4 video as my source and then auto-rotoscope it as seen in this tutorial video:


When I followed the steps in that video, it processed my source video for 10 hours (it's a 3 minute video clip) but the final video it rendered will not play no matter what application I use (I get an error message saying: This video was encoded in a format not accepted). I tried to save my videos as both .mov files as well as mp4 files and get the same error message every time time I attempt to play my videos, no matter what video player I use. I also am unable to import these files into any other program (Premiere, After Effects, etc.) because they are unreadable.

I WAS able to get a .mov file to work using the "Animate with Paint Action Sequence video" but the final video has an animated background with only a still image from my source video in the front (whereas what I want to achieve is to have the background AND the foreground "characters" animated as depicted in the tutorial video). So I made a 5 second source video in Premiere to test in Studio Artist without it taking 10 hours to process, and no matter what I try the "Process with Paint Action Sequence" method always gives me a file that will not play. It goes through the stages of processing my video frame by frame, and each frame it shows me looks perfect, but when it's done, the video it has exported simply will not play and is unreadable.

So I'm hoping someone can help me solve this issue. I am using a PC computer running Windows 10 Pro with 32g of ram and an AMD RYZEN 7 3700X 8 Core processor.

In a nutshell, I want to upload my MP4s and process my video clips so that they animate with the auto-rotoscope look. I love what the program is doing when it's processing, I just wish I could get the final videos it renders would play. I know it's probably just some little step that I'm doing wrong, although I followed every step in the video to a T so I'm not sure how to make it work right.

I have tested other quicktime files as well as other mp4s (not from Studio Artist) and they all play fine, so I know it's not an issue with my video players. They all claim to be up to date, as well.

In Peter's email, he mentioned the need on Windows to include an extension when processing output files. I have tried using both .mov and .mp4 with no luck whatsoever. I've tried to process my clips using every method I could think of, but all with the same error message.

Any help that anybody might be able to give me to rectify this issue would be greatly appreciated. Thanks so much for all your time and help!

Views: 118

Reply to This

Replies to This Discussion

OK, so on windows if you are running V4 or V5, you need to make sure you add a .mov file extension to the name of the movie file you are creating.

Otherwise the movie file you create will not have a file extension.

That didn't used to matter on mac, but on windows other programs need a file extension on any files they might want to open so that they know what kind of file it is.

In SA V4 and V5, the movie file output is a quicktime movie file.

So the file extension for a quicktime movie file is 'mov'.

So let's say you wanted to output a movie file named MyNewMovie

You would need to name it MyNewMovie.mov

If you forgot to do this, you can always add it manually later in the windows finder.

So whats the difference between Animate vs Process?

You have access to both in the main Action menu in Studio Artist.


Animate is really oriented at generating an animation from the PASeq timeline.

The number of frames in your animation will be the number of frames in the PASeq Timeline.

So you could build keyframed animation in that timeline.

Or you could have action steps with Temporal Generator (TG) in them doing modulation of individual editable parameters over time.


Process is really focused on processing a source to a destination.

If you look inside of the Action : Process with a PASeq menu

you will see different source an destination options you can pick.

If you want to process the source movie and output to a rendered movie file, then you choose the source to movie option.

If you choose movie to movie option, then it asks you for a source movie to process, then you name your putput movie.

There are other options there to go folder of images to folder of images.

You can also output eps or svg (careful, only action steps that generate eps or svg will output anything).

And of course you can mix and match src and dst, (so folder of images to movie file as one example).

If you are just interesting in processing the source movie to a rendered output movie, then you want to go with Action : Process rather than Action : Animate.

Special Cases:

If you setup the File: Source Settings correctly, so that a loaded source movie synched with the PASeq timeline, then you could run Animate and still have the source movie file advancing.  Other source settings would configure so the source movie still advanced, but wasn't necessarily synched with the current timeline frame.

The system is very flexible, so you can create weird processes for your weird special cases if you want to and then run them as animate.

I just want to process a movie to a movie

Here's a tutorial to help you through that process.

The other thing to be aware of is that you can set the quicktime codec used for movie file output.  There are many different codecs available.  Which ones in particular show up in SA is a function of what you have installed on your computer.  That's a quicktime thing, we aren't involved in that as all.

If you have't touched anything, then it's probably trying to default to animation codec.

Historically this was a good codec to use, since it allowed for lossless compression (nice if you want the highest quality output, that you might then later recompress with a lossy codec for uploading to the web, or whatever).  Animation codec is lossless when you use the highest quality settings.

You can access the quicktime codecs in SA using the File : Movie Compression Codec dialog.

You might want to try something like jpeg codec if you are having issues opening the files.

We have a ton of people who use Studio Artist on windows and open the files in Premiere.  You might have to import the file, as opposed to 'open' it.

I can ask someone who works with video on windows to comment about their exact procedure if you are still having issues.

I guess i should point out that all of this Quicktime specific stuff kind of goes away in upcoming SA V5.5.

More on that when V5.5 ships (which will be sooner rather than later).

Is there any chance the new releases will work in High Sierra?

Highly unlikely.  I was originally thinking Catalina osx 10.15 (since that is true for debug builds), but SA V5.5 release builds do run on Mojave osx 10.14.

Ok, i modified things (after your email to me about this), and i think we can target osx 10.13 for SA V5.5 release builds.  So we will try to do that unless something specific prevents us.  I think this will work for V5.5.

Thanks. I am so grateful.


Basically, what I'm trying to do is use a pre-exiting mp4 video as my source and then auto-rotoscope it as seen in this tutorial video:



So the tutorial movie is using Action : Process with PASeq : Source movie to Movie File.

Like i said, try another codec like the simple jpeg codec is you are running into issues getting the movie file output into another program. You can stop the render by pressing the spacebar at any time while it is running, so i'd just do a few frames as a test first, then manually kill it.

Make sure you add the .mov file extension to the file name. 

Thank you so much for all your super valuable input.  I will run a few more tests when I get home later and report back on my results!  Appreciate all your help.

I was able to get my video file to render/play successfully by tweaking the movie codec setting to MP4.  When I tried it with the jpeg codecs it still exported an unplayable file.  It's working on the mp4 setting, though, and looks great so I'll run with that.  Thank you so much again for your invaluable advice.  I'm sure I will be back again soon with additional questions.

Glad you got it working.

What version of Premiere are you using?  Latest, or an older one?

MP4 is fine for streaming out an entire movie file (as long as you are ok with lossy compression for your output).

The older non- temporal codecs were really useful for things like movie layers, where you are adding frames.  If you think about how temporal coding works, it introduces problems for single frame edits in the temporally compressed stream.

Apple especially kind of forgot about this use case in their rush to kill off Quicktime and move everything to AVFramework.  It's a very mypoic focus on 'video must be live' and screw you anyone who want to generate frames out of real time.

Of course they probably have some hidden api that Final Cut can use.

We're working towards allowing folders of images to work equivalently to movie files in V5.5 and beyond. So then we don't have to worry about the issue.

And supporting AVI on windows as an option for output.

I use the latest version of Premiere and all Adobe CC software.

I would prefer to have my rendered videos NOT have lossy compression, but I tried all of the other codec settings in SA and the MP4 one is the only one that gives me a playable video file.  Is this maybe because the source video clips are MP4S?  Or does that not make any difference. 

I will keep experimenting with different settings to see if I can fine tune things better.  Ultimately, I hope to do some frame-by-frame hand drawn animation in SA (I usually use Krita for that but I love the brushes in SA so I want to play around with that next).

Thanks again for all your help!  More soon!


Latest Activity

M A X posted a blog post

Andreas Baier's Flashlight-Paintings

Andreas take this shot in my studio, must be middle of the 90s or so. If someone'sinteresting in his awesome flashlight-technique: more infos and links via my tumblr-blog.Andreas is one of the most supercreative and multitalented guys i met...See More
6 hours ago
David Buckle posted a photo
10 hours ago
M A X posted a discussion


I like the refreshments and cosmetics of the synthetik-site:(The language pulldown menue to the autotranslation did not work for me on Iphone.)Thinking on corporate identity, i would like to see this stylesheets also here the SA userforum.thanksSee More
18 hours ago
Bernard Bunner commented on Bernard Bunner's photo

Abstract Outline

"I just had to restart my Mac. And now when I run these 2 "bug" presets, I don't have any problem ! Curious ! (I'm on Catalina 10.15.7)"
22 hours ago
Synthetik Software posted photos
23 hours ago
M A X posted a photo
23 hours ago
Synthetik Software commented on Bernard Bunner's photo

Abstract Outline

"Email me the presets for anything you consider a bug as you run across them and we'll look at them."
23 hours ago
Bernard Bunner commented on Bernard Bunner's photo

Abstract Outline

"John, these 2 bugs are "old" bugs. They also appears with SA 5."

© 2021   Created by Synthetik Software.   Powered by

Badges  |  Report an Issue  |  Terms of Service